Bug in Pause methods

Did you find an bug? Please be very specific with details how to reproduce the bug so we can fix it as soon as possible.

Bug in Pause methods

Postby tranxen » Sun Jan 21, 2018 2:21 am

Hello,
I am trying the Demo pack of AudioToolKit, which by the way looks promising, and I think that I have found a bug in the Pause methods.
The AudioController.PauseAll() & AudioController.PauseMusic() methods work perfectly when no argument is provided.
However, if you give them a float as an argument, they don't pause the audio files being played but only mute them after the fade (float) delay.

For exemple, you are playing a background music. At 10 seconds you pause the music with AudioController.PauseAll(0.5f) for 15 seconds. When you will Unpause, the audio will play at 25 seconds of the track instead of 10 seconds, where it was initially paused.
I have been able to inspect the corresponding AudioObject and using the refreshing button, I can see the time running during a PauseAll(float) call but not during a PauseAll() -no argument- call.
Same behaviour with PlayMusic(float).

For information, I have not tested the behaviour of following methods : PauseAmbienceSound & PauseCategory.
I don't know if the full version has this bug, and I sincerely hope that it hasn't since I am considering buying it to use these methods in my project.

Thank you for your feedback,
Tranxen
tranxen
 
Posts: 1
Joined: Sun Jan 21, 2018 1:42 am

Re: Bug in Pause methods

Postby clockstone » Sun Jan 28, 2018 2:26 pm

Thanks for your bug report. We will look into this issue!
User avatar
clockstone
Site Admin
 
Posts: 17
Joined: Mon Jan 13, 2014 3:18 am


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron